• Register
Welcome to MindMap Maker Forum. Found a bug please let us know. Think mind map maker lack a feature please give us a feature request.
0 votes

    Since this new version (with ads) came out I am not being able to save any map.

    I've tried on the following browsers: chrome, firefox and edge.

    Still love this app. Use it a lot.

     Hope this issue can be solved easily.


Thanks a lot for keeping this app running.


in Bugs by

2 Answers

0 votes


I have checked the app and it seemed to be running fine.

I can save the map in MindMaps server, to file and Google Drive.

What is the problem showing in your end? Can you send a screenshot?

Try installing this chrome extension to disable ads.




by (12.2k points)
Thanks for your quick reply.

I installed that chrome extension and ads are gone.

However, the saving problem still persists. Since it is not replicated there it might be a problem here.

Anyway, I am sending this video so you can see that nothing happens when I click on  Save As.


I dont know what is causing the problem.

I checked it in Microsoft Edge. It seems to be working fine. Check the screenshot.

Do one thing.
1. After clicking 'Save As'-> Send me the console message. Right Click in chrome and select 'Inspect'. Goto 'Console' tab and send me the screenshot of that tab.

2. Clear the mindmap app from your browser. Select Chrome Menu->More Tools->Clear Browsing Data... Then clear all time data. Then try reloading the mindmap webapp.

3. Also, you can try using mindmap from a browser where you have never the use the app before. Use a fresh browser.

0 votes
Your browser is somehow using the old version of this app. Thats why it is causing the error.

I have updated the app.

Goto http://app.mindmapmaker.org again. After sometime, the app will be updated.

After updation, check if the problem still persists.

If it still is there, send me the screenshot of console again.

Try a new browser, then it will use a fresh copy of the app. Then it will be okay I think.


2. Also try this.

In chrome browser, goto, chrome://appcache-internals/

There you will see app.mindmapmaker.org Remove that item.

Then goto app.mindmapmaker.org again. It will then install the updated copy of the app.

Let me know if it works.


3. Also try this. Inorder to delete the old version of mindmaps from your browser. Click, Chrome Menu->More Tools->Clear Browsing Data... Click on 'Advanced' and select 'All Time' from Time Range. Then select all items in the box to properly remove the mindmap app from your browser. It will take some time to clear the browser. Then relaunch http://app.mindmapmaker.org Check if the app is okay now. Regards,


by (12.2k points)